Supported Browsers

SurveyMonkey supports the following browsers:

  • Chrome 16 and later
  • Firefox 13.0 and later
  • Safari 5.0 or later
  • Internet Explorer 9.0 and later

For the best experience, we recommend downloading the newest version of your preferred browser.

Limitations for Internet Explorer 9

When creating a survey, you'll see a different experience than what's outlined in How to Create a Survey. But not to worry—you can still create a survey, make a copy of an existing survey, and use templates from the older version of the page.

To access the rich text editor when you're designing a survey in IE9, you need to click Edit Formatting in the upper right corner of the text field. Update your browser to use an inline rich text editor that you can use directly in the text field—without opening a new modal window.

View a list of browsers SurveyMonkey supports and limitations for Internet Explorer 9.

Get Answers Today